Knowledge Base

Integrate with Adobe Creative Cloud

You can now integrate with Adobe Creative cloud. The plugin allows you to use assets from Bynder in your InDesign file and upload files from disk directly to Bynder. Using the plugin also enables several designers to work concurrently on the same file.

When you use the plugin, you can use all the filters available in Bynder to search for assets. You can also use the high-res or a webversion of an asset.

Background information

  • Importing images from Bynder means importing a link. If you delete the asset you have used in an InDesign file from Bynder, the asset will no longer display in InDesign.
  • The assets you see and can use in InDesign depend on the permissions you have in Bynder.
  • When you import an asset, it is automatically saved to Bynder_connector_files > Documents folder. If you want to save your downloaded image to another location, go to Preferences and clear the Save to Bynder_files folder preference under Download Options. Then you will be able to choose a location whenever a file is downloaded. Enabling the Open file on download (if possible) preference will automatically open a downloaded image when the file has completed downloading.
  • You can upload a new asset to Bynder from your disk (Upload from Disk option).
  • When you send your InDesign file to the printer, make sure you send the entire package.
    Before you send the package, make sure the files in your Links folder have extensions. If they miss any, manually add .jpeg to your files in the folder.

Supported versions

Bynder Connector works with CC 2019, 2018 and 2017 (and later minor versions, such as 2017.1). InDesign, Photoshop, and Illustrator are the only supported applications. The plugin does not require Java or a specific version of a browser.

The plugin does not support 32-bit Windows.

Derivatives used

No additional derivative configuration is required for the plugin. The CC Connector makes use of the default smaller derivative for image previewing. When you add images to your InDesign, Photoshop or Illustrator file the plugin will make use of the original file. Currently, no other (custom) derivatives can be added to your InDesign, Photoshop or Illustrator file via the plugin.

Installation

Make sure you close Adobe InDesign and other CC applications before installing Bynder CC Connector.
  1. Contact your Bynder Customer Success Manager about the plugin. Alternatively, you can contact sales@siliconpublishing.com, which is the party that maintains the plugin.
  2. Download one of the package files necessary for the plugin to run:

    For Mac

    For Windows

  3. Download and install the Bynder CC plugin.

Configuration

  1. Open Adobe InDesign CC.
  2. From the main InDesign menu, choose Window > Extensions > Bynder CC Connector.
  3. Enter your licence key.
    • You need to pay a yearly licence fee for using the plugin. If you want to use the plugin in trial mode, you can only import 3 asstes from Bynder to InDesign. The trial is valid 30 days.
    • The plugin does not update automatically. Contact your Bynder Customer Success Manager about updates.
  4. In the Setup popup, enter the server name and the URL. The name and the URL in the screenshot are examples.
    Make sure the URL is exactly the same as the one showing on the login page to the environment. If the URL is incorrect you get a Type =500 error when trying to connect.

  5. Click Add Server to list.
  6. Make sure the Bynder metaproperties you use as filters in the plugin have the Apifilter option selected. If the do not, they will not be visible as filters in the plugin. To verify, go to Settings > Account > Metaproprties management, hover over the metaproperty and click the edit icon that appears.

Use the plugin

Use Bynder assets in InDesign
  1. From the main InDesign menu, choose Window > Extensions > Bynder CC Connector.
  2. Select the server from the Server list and click Connect.
    If you are getting a Type =500 error, it means the URL of the environment you are connecting to is incorrect.
  3. Log in to Bynder with your credentials.
    Currently SSO login is not supported so make sure to log in with your regular credentials. Also, currently, we do not support the expandable login section on the login page (when login credentials are displayed on clicking a link).
  4. To find your asset, expand the Filter drop-down list and select the filters you want to use. Close the filer drop-down list to see the applied filters. You can expand your search by clicking the X icon on the filer. Alternatively, you can use the search bar to look for specific assets.

  5. (Optional) Switch between the list and the grid view.

    list and grid view buttons

  6. Drag and drop the image into your InDesign, Photoshop or Illustrator file. You can resize the image if needed.
    You can see the first 100 images loaded. If you want to load more, click the + icon at the bottom of the page.

    home location in Bynder CC connector

  7. (Optional) To download a copy of an image from Bynder CC Connector to your computer, double-click the image you want to save and click the download arrow to start downloading.
Use Preferences in your Bynder CC Connector

preferences in bynder cc connector

  • Select Place Options > Replace selection on place to replace an already selected image in the file by dragging and dropping another image. If the option has been cleared, you cannot replace images by dragging and dropping a new image.
  • Select Place Options > Use high resolution on place to automatically use a full resolution version of the asset you are adding to your document. If you want to work with low-res images, clear this option.
  • Go to Links menu> Panel Options and select the Bynder checkboxes to add the Bynder Links tab options to your Links palette. In this way you can view and control the low-res and high-res state of assets in your document.

    panel options

  • Toggle between low-res (stair-step icon) and high-res versions of your added images by double-clicking the resolution icon in the Links tab.

Uninstall the plugin

  1. Remove your previously saved credentials and preferences.
    • To clear your saved credentials just log out from the Bynder Connector.
    • To clear your preferences, delete the Bynder_connector_files folder from your Documents folder.
  2. Deactivate the licence to use it again in the future.

    To deactivate the licence, go to the Bynder plugin menu and click Deactivate.

    deactivate licence

  3. Depending on the operating system you use do one of the following:
Mac users

Log out from InDesign and remove the following folders:

  • remove the extension folder:
    /Libraries/ApplicationSupport/Adobe/CEP/extensions/BynderCCConnector.
  • remove the plug-in folder:
    /Applications/Adobe InDesign CC 201X/Plug-Ins/SiliconConnectorBynder. (folder name depends on your version)
Windows users

Quit InDesign and go to Control Panel > Programs > Uninstall a Program and uninstall any previous installations of BYNDER CC 2017/2018.

Limitations

  • Versions do not automatically get updated in InDesign if a new version of an asset has been uploaded to Bynder.
  • The plugin does not support SSO or Google SSO.

Learn more