Knowledge Base

Integrate with Adobe Creative Cloud

You can now integrate with Adobe Creative cloud. The plugin allows you to use assets from Bynder in your InDesign file and upload files from disk directly to Bynder. Using the plugin also enables several designers to work concurrently on the same file.

When you use the plugin, you can use all the filters available in Bynder to search for assets. You can also use the high-res or a webversion of an asset.

Watch a video

Background information

  • Importing images from Bynder means importing a link. If you delete the asset you have used in an InDesign file from Bynder, the asset will no longer display in InDesign.

  • The assets you see and can use in InDesign depend on the permissions you have in Bynder.

  • When you import an asset, it is automatically saved to Bynder_connector_files > Documents folder. If you want to save your downloaded image to another location, go to Preferences and clear the Save to Bynder_files folder preference under Download Options. Then you will be able to choose a location whenever a file is downloaded. Enabling the Open file on download (if possible) preference will automatically open a downloaded image when the file has completed downloading.

  • You can upload a new asset to Bynder from your disk (Upload from Disk option).

  • When you send your InDesign file to the printer, make sure you send the entire package.

    Note

    Before you send the package, make sure the files in your Links folder have extensions. If they miss any, manually add .jpeg to your files in the folder.

Supported versions

Bynder will support the latest 2 versions of Adobe Creative Cloud for InDesign, Photoshop, and Illustrator. The plugin does not require Java or a specific version of a browser.

Note

  • CC 2019 is supported till the end of 2020.

  • The plugin does not support 32-bit Windows.

Derivatives used

No additional derivative configuration is required for the plugin. The CC Connector makes use of the default smaller derivative for image previewing. When you add images to your InDesign, Photoshop or Illustrator file the plugin will make use of the original file. Currently, no other (custom) derivatives can be added to your InDesign, Photoshop or Illustrator file via the plugin.

Installation

Note

Make sure you close Adobe InDesign and other CC applications before installing Bynder CC Connector.

  1. Contact your Bynder Customer Success Manager about the plugin. Alternatively, you can contact sales@siliconpublishing.com, which is the party that maintains the plugin.

  2. Download the latest version of the package file below.

    For Mac (version 1.3.17)

    For Windows (version 1.3.15)

  3. Download and install the Bynder CC plugin.

Configuration

  1. Open Adobe InDesign CC.

  2. From the main InDesign menu, choose Window > Extensions > Bynder CC Connector.

  3. Enter your license key.

    Note

    • You need to pay a yearly license fee for using the plugin. If you want to use the plugin in trial mode, you can only import 3 assets from Bynder to InDesign. The trial is valid 30 days.

    • The plugin does not update automatically. Contact your Bynder Customer Success Manager about updates.

  4. In the Setup popup, enter the server name and the URL. The name and the URL in the screenshot are examples.

    Note

    Make sure the URL is exactly the same as the one showing on the login page to the environment. If the URL is incorrect you get a Type =500 error when trying to connect.

    connector.png
  5. Click Add Server to list.

  6. Make sure the Bynder metaproperties you use as filters in the plugin have the Apifilter option selected. If the do not, they will not be visible as filters in the plugin. To verify, go to Settings > Account > Metaproprties management, hover over the metaproperty and click the edit icon that appears.

Use the plugin

Use Bynder assets in InDesign
  1. From the main InDesign menu, choose Window > Extensions > Bynder CC Connector.

  2. Select the server from the Server list and click Connect. The browser will open and you'll be redirected to the login page of the portal.

    Note

    If you are getting a Type =500 error, it means the URL of the environment you are connecting to is incorrect.

  3. Log in to Bynder using SSO or your credentials.

  4. Grant the Adobe CC Connector (Silicon Publishing) access to your portal by clicking Yes. Once the authorization is successful you can close the browser window/tab.

  5. To find your asset, expand the Filter drop-down list and select the filters you want to use. Close the filer drop-down list to see the applied filters. You can expand your search by clicking the X icon on the filer. Alternatively, you can use the search bar to look for specific assets.

    filters-bynder-cc-connector.png
  6. (Optional) Switch between the list and the grid view.

    view-bynder-cc-connector.png
  7. Drag and drop the image into your InDesign, Photoshop or Illustrator file. You can resize the image if needed.

    Note

    You can see the first 100 images loaded. If you want to load more, click the + icon at the bottom of the page.

    adobe-cc-plugin.png
  8. (Optional) To download a copy of an image from Bynder CC Connector to your computer, double-click the image you want to save and click the download_adobe_cc_connector.png button to start downloading.

    Note

    This option is only availble if the Save to Bynder_files folder option is enabled under preferences.

Select the Resolution Used for Previewing Bynder Assets in InDesign

You can switch between a high-res and low-res preview version of your Bynder assets in InDesign. Using low-res preview files can increase performance in InDesign.

  1. Go to Windows > Links, which will enable the Links panel into your workspace.

  2. Click the menu_cc_connector.png button in the Links panel and click Panel Options. A new screen will open.

  3. Scroll to the Bynder option and select the Show column and Show in Link Info check boxes to add the Bynder Links tab options to your Links palette. This way, you can view and control the low-res and high-res state of assets in your document.

    panel-options.png

    Click to enlarge

  4. Toggle between low-res (stair-step icon) and high-res versions of your added images by double-clicking the resolution icon in the Links tab.

    resolution_cc_connector.png
Version Updates

The CC Connector automatically detects when a new version of an asset is uploaded to Bynder. The warning_adobe.png symbol in the Links tab will notify you that a new version is available. Click the symbol to automatically update to the latest version.

How to Upload Your Indesign Files and Ingredients to Bynder?

Do you want to share your InDesign file without having to worry about missing links when other users using the Adobe CC Connector open it? By storing your InDesign and ingredient files in Bynder and by making sure the ingredient files are linked to your Bynder assets you'll no longer have this problem.

Find out below how you can upload your InDesign files to Bynder and relink your ingredients.

Note

The below features are only available for InDesign.

Upload a Specific Ingredient File to Bynder

Follow the steps below if a specific ingredient file isn't available in your Bynder portal yet.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Select the image in your document that you want to upload to Bynder.

  3. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Upload Selected.

The file will be uploaded to your portal. It may take a while before it's available in the portal and Adobe CC Connector.

Upload all Ingredient Files to Bynder

Follow the steps below if you want to upload all ingredient files that aren't available in your Bynder portal yet.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Upload all non-HTTP Assets.

The files will be uploaded to your portal. It may take a while before they're available in the portal and Adobe CC Connector.

Upload your InDesign File to Bynder

Follow the steps below to upload your InDesign file to Bynder. All the ingredient files that are linked to your Bynder portal will remain linked. This way, other users who open the InDesign file and have the Adobe CC Connector installed won't experience any missing links.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Save file to Bynder.

The file will be uploaded to your portal. It may take a while before it's available in the portal and Adobe CC Connector.

Relink your Ingredient Files to Bynder

Did you add an image which was stored locally on your device to your InDesign document? In some cases you may have used a local file that is also stored in your Bynder portal. By relinking the file you ensure that the ingredient file is connected to the Bynder asset. This way, other users using the Adobe CC Connector won't experience any missing links if they open your InDesign document.

I Want to Relink One Ingredient File
  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Select the image in your document that you want to relink to a Bynder asset.

  3. Locate the Bynder asset in the Bynder CC Connector window by using the available filters and search bar.

  4. Right click the Bynder asset and click Relink to Asset.

I want to Relink Multiple Ingredient Files
  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Check the total number of assets that are available in the Adobe CC Connector panel. You can find this number at the bottom of the panel. If the number is higher than 1000 use the available filters and search bar to narrow this number down to 1000 assets or less. This is necessary because when relinking the connector can only search through a maximum number of 1000 assets.

  3. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Relink Assets and wait for the connector to finish the relinking process.

Preferences in your Bynder CC Connector
preferenes-bynder-cc-connector.png
Place Options
  • Select Place Options > Replace selection on place to replace an already selected image in the file by dragging and dropping another image. If the option has been cleared, you cannot replace images by dragging and dropping a new image.

  • Select Place Options > Use high resolution on place to automatically use a full resolution version of the asset you are adding to your document. If you want to work with low-res images, clear this option.

Download Options
  • Select Open file on download if you want the files to automatically open after download.

  • Select Save to Bynder_files folder if you want to download your Bynder assets using the connector and store them locally.

    Note

    If this option is not enabled you cannot use the Adobe CC connector to download your Bynder assets.

Asset View
  • Select Use Grid view if you want the assets in the Adobe CC Connector to be displayed in a grid.

  • Select Use List view if you want the assets in the Adobe CC Connector to be displayed in a list.

Troubleshooting
  • Select the Write to log file option if you want the activity in the Adobe CC Connector to be logged. A log file can help support to better troubleshoot any issues you may encounter using the connector. You can clear the log by clicking the Clear Log File button.

Uninstall the plugin

  1. Remove your previously saved credentials and preferences.

    • To clear your saved credentials just log out from the Bynder Connector.

    • To clear your preferences, delete the Bynder_connector_files folder from your Documents folder.

  2. Deactivate the license to use it again in the future.

    To deactivate the license, click Bynder in the top menu bar and click Deactivate.

    deactivate-licence.png
  3. Depending on the operating system you use do one of the following:

Mac users

Log out from InDesign and remove the following folders:

  • remove the extension folder:

    /Libraries/ApplicationSupport/Adobe/CEP/extensions/BynderCCConnector.

  • remove the plug-in folder:

    /Applications/Adobe InDesign CC 201X/Plug-Ins/SiliconConnectorBynder. (folder name depends on your version)

Windows users

Quit InDesign and go to Control Panel > Programs > Uninstall a Program and uninstall any previous installations of BYNDER CC 2017/2018.

Learn more