Skip to main content

Knowledge Base

Integrate With Adobe Creative Cloud

Would you like to use your Bynder assets in Adobe Creative Cloud? You no longer have to download your assets first. Instead you can now directly add them to your Adobe content using our Adobe Creative Cloud plugins.

We offer two connectors that you can use to integrate with Adobe. Click the dropdown of the connector you have installed below and start using your Bynder assets in your Adobe content.

Tip

Do you already have a connector installed and are you not sure which one you have?

Open your Adobe software and go to Window > Extensions.

Here it will show if you have the Adobe CC Connector or LinkrUI installed.

Select one of the Connectors Below

Would you like to use your Bynder assets in Adobe Creative Cloud? You no longer have to download your assets first. Instead you can now directly add them to your Adobe content using our Adobe Creative Cloud plugins.

The plugin allows you to use assets from Bynder in your Adobe Content such as InDesign or Photoshop files. In addition, you can also upload files from your disk directly to Bynder. Using the plugin also enables several designers to work concurrently on the same file.

When you use the plugin, you can use all the filters available in Bynder to search for assets. You can configure whether you want the integration to add the high-res or the webversion of an asset to your Adobe content.

Watch a video
Background information
  • Importing images from Bynder means importing a link. If you delete the asset you have used in an InDesign file from Bynder, the asset will no longer display in InDesign.

  • The assets you see and can use in InDesign depend on the permissions you have in Bynder.

  • When you import an asset, it is automatically saved to Bynder_connector_files > Documents folder. If you want to save your downloaded image to another location, go to Preferences and clear the Save to Bynder_files folder preference under Download Options. Then you will be able to choose a location whenever a file is downloaded. Enabling the Open file on download (if possible) preference will automatically open a downloaded image when the file has completed downloading.

  • You can upload a new asset to Bynder from your disk (Upload from Disk option).

  • When you send your InDesign file to the printer, make sure you send the entire package.

    Note

    Before you send the package, make sure the files in your Links folder have extensions. If they miss any, manually add .jpeg to your files in the folder.

Supported versions

Bynder will support the latest 2 versions of Adobe Creative Cloud for InDesign, Photoshop, and Illustrator. The plugin does not require Java or a specific version of a browser.

Note

  • CC 2019 is supported till the end of 2020.

  • The plugin does not support 32-bit Windows.

Derivatives used

No additional derivative configuration is required for the plugin. The CC Connector makes use of the default smaller derivative for image previewing. When you add images to your InDesign, Photoshop or Illustrator file the plugin will make use of the original file. Currently, no other (custom) derivatives can be added to your InDesign, Photoshop or Illustrator file via the plugin.

Installation

Note

Make sure you close Adobe InDesign and other CC applications before installing Bynder CC Connector.

  1. Contact your Bynder Customer Success Manager about the plugin. Alternatively, you can contact sales@siliconpublishing.com, which is the party that maintains the plugin.

  2. Download the latest version of the package file below.

    For Mac (version 2.1.5)

    For Windows (version 2.1.5)

  3. Download and install the Bynder CC plugin.

Configuration
  1. Open Adobe InDesign CC.

  2. From the main InDesign menu, choose Window > Extensions > Bynder CC Connector.

  3. Enter your license key.

    Note

    • You need to pay a yearly license fee for using the plugin. If you want to use the plugin in trial mode, you can only import 3 assets from Bynder to InDesign. The trial is valid 30 days.

    • The plugin does not update automatically. Contact your Bynder Customer Success Manager about updates.

  4. In the Setup popup, enter the server name and the URL. The name and the URL in the screenshot are examples.

    Note

    Make sure the URL is exactly the same as the one showing on the login page to the environment. If the URL is incorrect you get a Type =500 error when trying to connect.

    connector.png
  5. Click Add Server to list.

  6. Make sure the Bynder metaproperties you use as filters in the plugin have the Apifilter option selected. If the do not, they will not be visible as filters in the plugin. To verify, go to Settings > Account > Metaproperties management, hover over the metaproperty and click the edit icon that appears.

Use the plugin
Use Bynder assets in InDesign
  1. From the main InDesign menu, choose Window > Extensions > Bynder CC Connector.

  2. Select the server from the Server list and click Connect. The browser will open and you'll be redirected to the login page of the portal.

    Note

    If you are getting a Type =500 error, it means the URL of the environment you are connecting to is incorrect.

  3. Log in to Bynder using SSO or your credentials.

  4. Grant the Adobe CC Connector (Silicon Publishing) access to your portal by clicking Yes. Once the authorization is successful you can close the browser window/tab.

  5. To find your asset, expand the Filter drop-down list and select the filters you want to use. Close the filer drop-down list to see the applied filters. You can expand your search by clicking the X icon on the filer. Alternatively, you can use the search bar to look for specific assets.

    filters-bynder-cc-connector.png
  6. (Optional) Switch between the list and the grid view and/or use the available filters to sort the results by filename (alphabetical) or date added and ascending or descending.

    view-bynder-cc-connector.png
  7. Drag and drop the image into your InDesign, Photoshop or Illustrator file. You can resize the image if needed.

    Note

    You can see the first 100 images loaded. If you want to load more, click the + icon at the bottom of the page.

    adobe-cc-plugin.png
  8. (Optional) To download a copy of an image from Bynder CC Connector to your computer, double-click the image you want to save and click the download_adobe_cc_connector.png button to start downloading.

    Note

    This option is only availble if the Save to Bynder_files folder option is enabled under preferences.

Select the Resolution Used for Previewing Bynder Assets in InDesign

You can switch between a high-res and low-res preview version of your Bynder assets in InDesign. Using low-res preview files can increase performance in InDesign.

  1. Go to Windows > Links, which will enable the Links panel into your workspace.

  2. Click the menu_cc_connector.png button in the Links panel and click Panel Options. A new screen will open.

  3. Scroll to the Bynder option and select the Show column and Show in Link Info check boxes to add the Bynder Links tab options to your Links palette. This way, you can view and control the low-res and high-res state of assets in your document.

    panel-options.png

    Click to enlarge

  4. Toggle between low-res (stair-step icon) and high-res versions of your added images by double-clicking the resolution icon in the Links tab.

    resolution_cc_connector.png
Version Updates

The CC Connector automatically detects when a new version of an asset is uploaded to Bynder. The warning_adobe.png symbol in the Links tab will notify you that a new version is available. Click the symbol to automatically update to the latest version.

How to Upload Your Indesign Files and Ingredients to Bynder?

Do you want to share your InDesign file without having to worry about missing links when other users using the Adobe CC Connector open it? By storing your InDesign and ingredient files in Bynder and by making sure the ingredient files are linked to your Bynder assets you'll no longer have this problem.

Find out below how you can upload your InDesign files to Bynder and relink your ingredients.

Note

The below features are only available for InDesign.

Upload a Specific Ingredient File to Bynder

Follow the steps below if a specific ingredient file isn't available in your Bynder portal yet.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Select the image in your document that you want to upload to Bynder.

  3. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Upload Selected.

The file will be uploaded to your portal. It may take a while before it's available in the portal and Adobe CC Connector.

Upload all Ingredient Files to Bynder

Follow the steps below if you want to upload all ingredient files that aren't available in your Bynder portal yet.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Upload all non-HTTP Assets.

The files will be uploaded to your portal. It may take a while before they're available in the portal and Adobe CC Connector.

Upload your InDesign File to Bynder

Follow the steps below to upload your InDesign file to Bynder. All the ingredient files that are linked to your Bynder portal will remain linked. This way, other users who open the InDesign file and have the Adobe CC Connector installed won't experience any missing links.

  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Save file to Bynder.

The file will be uploaded to your portal. It may take a while before it's available in the portal and Adobe CC Connector.

Relink your Ingredient Files to Bynder

Did you add an image which was stored locally on your device to your InDesign document? In some cases you may have used a local file that is also stored in your Bynder portal. By relinking the file you ensure that the ingredient file is connected to the Bynder asset. This way, other users using the Adobe CC Connector won't experience any missing links if they open your InDesign document.

I Want to Relink One Ingredient File
  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Select the image in your document that you want to relink to a Bynder asset.

  3. Locate the Bynder asset in the Bynder CC Connector window by using the available filters and search bar.

  4. Right click the Bynder asset and click Relink to Asset.

I want to Relink Multiple Ingredient Files
  1. Open your InDesign document and make sure the Adobe CC Connector is connected to your portal.

  2. Check the total number of assets that are available in the Adobe CC Connector panel. You can find this number at the bottom of the panel. If the number is higher than 1000 use the available filters and search bar to narrow this number down to 1000 assets or less. This is necessary because when relinking the connector can only search through a maximum number of 1000 assets.

  3. Click the menu_cc_connector.png button in the Bynder CC Connector window and click Relink Assets and wait for the connector to finish the relinking process.

Preferences in your Bynder CC Connector
preferenes-bynder-cc-connector.png
Place Options
  • Select Place Options > Replace selection on place to replace an already selected image in the file by dragging and dropping another image. If the option has been cleared, you cannot replace images by dragging and dropping a new image.

  • Select Place Options > Use high resolution on place to automatically use a full resolution version of the asset you are adding to your document. If you want to work with low-res images, clear this option.

Download Options
  • Select Open file on download if you want the files to automatically open after download.

  • Select Save to Bynder_files folder if you want to download your Bynder assets using the connector and store them locally.

    Note

    If this option is not enabled you cannot use the Adobe CC connector to download your Bynder assets.

Asset View
  • Select Use Grid view if you want the assets in the Adobe CC Connector to be displayed in a grid.

  • Select Use List view if you want the assets in the Adobe CC Connector to be displayed in a list.

Troubleshooting
  • Select the Write to log file option if you want the activity in the Adobe CC Connector to be logged. A log file can help support to better troubleshoot any issues you may encounter using the connector. You can clear the log by clicking the Clear Log File button.

Uninstall the plugin
  1. Remove your previously saved credentials and preferences.

    • To clear your saved credentials just log out from the Bynder Connector.

    • To clear your preferences, delete the Bynder_connector_files folder from your Documents folder.

  2. Deactivate the license to use it again in the future.

    To deactivate the license, click Bynder in the top menu bar and click Deactivate.

    deactivate-licence.png
  3. Depending on the operating system you use one of the following:

Mac users

Log out from InDesign and remove the following folders:

  • remove the extension folder:

    /Libraries/ApplicationSupport/Adobe/CEP/extensions/BynderCCConnector.

  • remove the plug-in folder:

    /Applications/Adobe InDesign CC 201X/Plug-Ins/SiliconConnectorBynder. (folder name depends on your version)

Windows users

Quit InDesign and go to Control Panel > Programs > Uninstall a Program and uninstall any previous installations of BYNDER CC 2017/2018.

Learn more

Would you like to use your Bynder assets in Adobe Creative Cloud? You no longer have to download your assets first. Instead you can now directly add them to your Adobe content using the LinkrUI Connector.

The LinkrUI Connector is a plugin, which allows you to use assets from Bynder in Adobe content. The Connector can be used in InDesign, Photoshop, Illustrator and Premiere and After Effects. When your Adobe file is ready you can use the connector to directly upload it to Bynder.

Using the connector can be a huge time saver as you don't have to leave Adobe anymore to find what you need. You can search and filter your assets, access your Bynder collections and check the asset details and metadata all from within the connector.

Skip Directly To

How to Enable the LinkrUI Connector?

Contact your Customer Success Manager if you're interested in the LinkrUI connector. Your Customer Success Manager will be happy to further assist you.

How to Download and Install the Connector?

The Adobe Connector provided by LinkrUI is a paid solution.

  1. Click one of the available download links below to download the Adobe CC Connector from LinkrUI.

  2. (For Windows only) Unzip the ZIP file.

  3. Install the installation file on your machine.

  4. Open your Adobe software.

  5. Make sure the LinkrUI panel is opened. Go to Window > Extensions > LinkrUI to enable it. You'll be asked if you already have an activation code.

  6. Click Yes to proceed.

  7. Enter your name in the Name field.

  8. Enter your email address in the Email field.

  9. Enter the activation code Bynder provided you with in the Activation Key field.

  10. Click the Activate button to activate your license.

You can now start using the LinkrUI Connector. Read more about using the connector in the sections below.

How to Use the Connector?

By default, the plugin shows all the assets you have access to. You can search and filter the assets to find what you're looking for.

There's no need to leave Adobe if you want to check the metaproperties and other metadata your assets are tagged with. The plugin can show you this information right from within Adobe. The plugin also allows you to access your collections.

Quick Start Guide
  1. Make sure the LinkrUI panel is opened. Go to Window > Extensions > LinkrUI to enable it. The extension will ask you to log in to your Bynder portal.

  2. Enter your Bynder portal URL in the Server URL field and click Authenticate. A browser window should open to authenticate. If this is not the case copy the full URL from the connector screen and visit the URL in your browser.

    Log in to the portal the usual way. If your login is successful the following message will appear: "Authentication complete. Please return to the LinkrUI panel in your Adobe application". If successful, return to your Adobe application and click the Close button in the LinkrUI panel. The portal assets will be loaded.

    Try logging in again if the authentication was not successful.

  3. (Optional) Search and filter your assets or open a collection.

  4. Drag and drop a Bynder asset to your Adobe content. Depending on the Adobe software you're using there may be additional steps to place the image into your actual content.

How to Add Bynder Assets to Your Adobe Content?
  1. Locate the Bynder asset you want to add to your Adobe content in the LinkrUI plugin using the available filters and/or search bar. You can also open a collection to find the asset you're looking for.

  2. Drag and drop a Bynder asset to your Adobe content. Depending on the Adobe software you're using there may be additional steps to place the image into your actual content.

How to Upload Your Adobe Files to Bynder?

With the LinkrUI plugin you can add your Bynder assets to your Adobe files. Did you know that you can also upload your Adobe file to Bynder without having to leave the Adobe suite? Follow the steps below to directly upload your Adobe file to your Bynder portal.

  1. Make sure the Adobe file you're working on is saved.

  2. Click the linkrui_menu.png button and click Upload New Asset.

  3. (Optional) Change the name of your new Bynder asset in the Name field.

  4. (Optional) Add a description for the new asset in the Description field.

  5. (Optional) Add your asset to a collection by selecting the available collections in the Collection section.

    Note

    Scroll down in the Collection section to load more collections.

  6. Click the Upload button to upload your Adobe file as a new asset to your Bynder portal.

How to Change the View?

There are two types of views available in the asset overview panel in the Connector.

  • Grid View

    The grid view shows the thumbnails of the assets and a small part of the asset title.

    Click the grid_view.png button to enable the grid view.

  • List View

    The list view shows more asset information and can show more assets compared to the grid view.

    Click the list_view.png button to enable the list view.

Tip

Did you know you can change the size of the thumbnails in the LinkrUi panel?

Read more about customizing the size of the thumbnails here.

How to Search and Filter Assets Inside the Connector?

Click the filter_linkrui.png button at the top of the panel to filter the assets by tags, file types or your available smart filters. Select the appropriate values and click Show results to filter your assets.

You can also use the search bar at the top of the panel to find the asset(s) you're looking for.

How to Access Collections in the Connector?

Open the All ᐯ dropdown at the top of the panel to open the list with collections you have access to. Click a name of a collection to see the assets that are inside the collection.

How to View Asset Metadata in the Connector?
  1. Click the asset of which you want to view the metadata.

  2. Click the linkrui_detail_view.png button. A Details panel will appear.

  3. Scroll down in the Details panel to see all the available metaproperties, tags and other information the asset is tagged with

    Tip

    Right click metadata and click Copy to copy the metadata.

    .

  4. (Optional) Select another asset in the plugin to view the asset detail data of that asset.

Further Explore the LinkrUI Connector

Explore all the other options and features that are available in the LinkrUI connector below.

  1. Make sure the LinkrUI panel is opened. Go to Window > Extensions > LinkrUI to enable it.

  2. Click the linkrui_menu.png button and check one of the options below.

    • Login

      Click Login to log in to the LinkrUI connector when you're not logged in.

      Enter your Bynder portal URL in the Server URL field and click Authenticate. A browser window should open to authenticate. If this is not the case copy the full URL from the connector screen and visit the URL in your browser.

      Log in to the portal the usual way. If your login is successful the following message will appear: "Authentication complete. Please return to the LinkrUI panel in your Adobe application". If successful, return to your Adobe application and click the Close button in the LinkrUI panel. The portal assets will be loaded.

      Try logging in again if the authentication was not successful.

    • Upload New Asset

      Read more about uploading your Adobe file as a new Bynder asset here.

    • Preferences

      Scroll through the preferences section to see all the available preferences.

      • Asset size

        Drag the slider to set the display size of the thumbnails in the panel of the connector. The thumbnail preview shows you how big the thumbnail will be.

      • Local Asset Cache Purge Interval

        This setting allows you to set after how much time your cached assets will be cleared. This means that the assets that are cached locally will be removed.

        Tip

        We advise using an interval that equals the time of the project you're working on in Adobe. If your project will take a week set the interval to After a week.

      • Local Asset Cache Folder

        Click Choose to select the folder on your local machine where the cached assets can be stored.

        Click Clear Cache to empty the above folder and to remove all cached assets.

      • Link Updates This option can decide what happens when there's a new version of the assets that are used in your Adobe file.

        For example, when you're using a Photoshop file in your InDesign file. If you upload your InDesign file to the cloud and another user open this InDesign file and modifies the Photoshop file. With the Link Updates option you can decide what happens the next time you open this InDesign file again.

        Auto update - This will ensure that the latest version of the assets in your Adobe file will be retrieved automatically. In the above example the new Photoshop file will be retrieved.

        Prompt - You'll be asked whether you want to retrieve the latest version of your assets used in your Adobe file. In the above example you'll be asked if you want to retrieve the latest version of the Photoshop file.

        Do nothing - The latest version of the assets used in your Adobe file won't be retrieved. In the above example the latest version of the Photoshop file won't be retrieved and you won't be asked to retrieve it.

    • Log out

      Click Log out to disconnect the LinkrUI connector from your Bynder portal.

    • Check Connections

      Use this option if you're experiencing issues with the LinkrUI connector to make sure the connector is connected correctly.

    • Uploads

      Click this option to see the Adobe files that are currently being uploaded to your Bynder portal. Read more about uploading your Adobe file to your Bynder portal here.

      If the Upload screen is empty there are currently no files being uploaded.

    • Refresh

      This option will refresh the panel of the LinkrUI connector. Click this option if you're not seeing the thumbnails in the connector or if you're having other issues.

    • Logging

      This option allows you to set the level of logging. Click the Logging dropdown, select one of the available options and click OK to save the option.

      Note

      The LinkrUI also has automated logging built in.

    • About

      Click this option to see which version of the LinkrUI connector currently is installed.

    • Contact Support

      Click this option when you need technical assistance with the LinkrUI connector.

    Tip

    Click Reset Preferences to go back to the default setup of the LinkrUI connector. This action can't be undone.

Learn More