Knowledge Base

Prepare Brand Template files

You can create the source files of Brand Templates with Photoshop (.PSD) or Sketch (.SKETCH). Read more about the general rules of creating your template file and start making your own Brand Templates.

Document dimensions

The dimensions of your template in Bynder are fixed and are based on the initial Sketch or Photoshop file that you upload. You cannot change the dimensions in Bynder. If you need the same document in two different dimensions (e.g. 800x800 banner, and 600x600 banner), you can create two separate source files and upload them as two separate templates.

Pages and Artboards

  • Multiple artboards or multiple pages are not supported in Brand Templates, which means that your document can only contain one artboard and one page.
  • If you upload a file with more than one artboard, the tool will create a template based on the first one and the rest of the artboards will be ignored.

  • Remove all hidden layers on your page or artboard. They are not supported as they can show up in the created template and affect its usability.

Sketch

To place artboards in separate Sketch files:

  • Select an artboard and copy it by clicking Edit>Copy.
  • Click File>New to create a new Sketch file.
  • Click Edit>Paste to paste the artboard in the new file.
  • Save the file by clicking File>Save.


Include the name of the channel in your filename to automatically categorize it under the right channel, for example Instagram Story or Googleadwords banner.

Photoshop

Artboards do not have to be used in Photoshop, since the uploader supports files with artboards as well as without. A single file cannot have more than one artboard. You can export additional ones to separate files by selecting File>Export>Artboards to files.


Layers

Give a unique name to your elements or layers in Photoshop or Sketch, so that you can easily recognize them in Bynder. In Brand Templates we make use of the same names.


Dynamic elements

There are three different kinds of dynamic elements you can have in a template:

Text frames

In both Photoshop and Sketch, elements placed inside text and image frames can only be dynamic as long as no other element is placed on top. If there are overlapping elements, end users will only be able to click and modify the element that is placed on top.

The dimensions of the text frame are set in Sketch or Photoshop and these cannot be changed in Bynder.

You can only use one font/style per text frame. If you want to use two different text styles, make sure to create two separate text frames. For example one for the header text and one for the body text.

Bynder supports the following font formats:

  • .OTF
  • .TTF

The font files used in the Sketch or Photoshop file need to be uploaded to Bynder separately. See [another article].

Sketch

The format of the text frame should be Fixed. This allows you to specify the dimensions of the text frame instead of them being set automatically based on the placeholder text.


Photoshop

All text needs to be converted to paragraph text in Photoshop. To do this, right click on the text frame and choose Convert to Paragraph Text.


Image frames

The size and dimensions of the image frame in your Brand Template are determined by the Sketch or Photoshop file that you upload.

You cannot change the dimensions of image frames in Bynder.


Flattening objects to bitmap

Grouping a shape and an image (creating a mask) is not supported. Flatten the grouped object into a bitmap, if you have applied a mask to an image in Sketch or Photoshop.

Sketch

In Sketch, select the object you wish to flatten and go to Layer>Flatten selection to bitmap.


Photoshop

Follow the instructions below to flatten an object in Photoshop.

  1. Select the layers you want to flatten.
  2. Right-click one of the layers.
  3. Choose Merge layers from the menu.


Color fills

You can apply color fills to the image. Color fills will work even if the image is changed in the template, though you will not be able to adjust the color fills themselves from how they were set up in the original file.

In Photoshop image color overlays are not supported.

Sketch

Select the image you want to add the effect to. In the style section, go to Fills and click + to add a color fill.

In the example below, a transparent black overlay is added to the image layer.


Effects

Effects are not supported in Brand Templates. Make sure that there are no effects applied to your images. Images should not be flipped or rotated. Some effects may be replicated in the output file, but not template editor. Other effects will not work at all.

Artboard backgrounds

You can assign a background color to the template. If a background color is not set, the background in the generated output files will be transparent.

Gradient colors are not supported. The opacity of the background color should always be set to 100%.

Sketch

The background color is not turned on automatically. Tick the checkbox background color in the right panel and set your background color.

Photoshop

  1. Select the artboard for which you want to set the background color.
  2. Go to Window>Properties to open the properties window.
  3. Set your background color in the Artboard background color section.


Shapes

Sketch

We only support flat images (bitmaps) and text layers in Sketch files. All other element types will be ignored by the system. Make sure to flatten any other type of element into bitmaps instead.

The shape of the resulting flat image will always be rectangular.
If you flatten a non-rectangular shape, parts of the background color may be included in the image as well. To avoid this, pull the shape outside the canvas, flatten it there and move it back onto the background.


Photoshop

In Photoshop files, shapes are supported and do not need to be flattened.